Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Needed to make some changes to make the old Qt4 ROS Kinetic GUI compile with Qt5 ROS Melodic. These were:

  • Renaming the QtGui include to QtWidget
  • package.xml according to: https://github.com/facontidavide/PlotJuggler/blob/master/package.xml#L27-L31
  • CMakeLists according to: https://gist.github.com/facontidavide/b397b64e35cf8284382009ab6ad959f8

It's now using only "non-ROS" Qt libraries.

Needed to make some changes to make the old Qt4 ROS Kinetic GUI compile with Qt5 ROS Melodic. These were:

  • Renaming the QtGui include to QtWidget
  • package.xml according to: https://github.com/facontidavide/PlotJuggler/blob/master/package.xml#L27-L31
  • CMakeLists according to: https://gist.github.com/facontidavide/b397b64e35cf8284382009ab6ad959f8

It's now using only "non-ROS" Qt libraries.

I made a package template here: https://github.com/jstiefel/qt5_ros_melodic_gui