Ask Your Question

Revision history [back]

In your amcl_diff_with_map_hwk.launch file, you have odom_frame_id listed twice, once near the top with the value of odom_combined and once near the bottom with the value odom. When you have the same parameter listed multiple times, it retains the last value set, in this case, odom. Your transform_tolerance parameter has the same problem.

Remove the extra lines so that you are only setting the parameters once to the value you want and it should work.