Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

You should include your launch file too so that we can reproduce your error.

I manage to get the same error as in your image by omitting to launch the node robot_state_publisher you seem to be launching just the joint_state_publisher node but you need both.

So a basic launch file without gazebo should be like this and wouldn't give you the same error :

<launch>

  <arg name="model" default="$(find myrobot)/urdf/myrobot.urdf.xacro"/>

  <!--  ******************** Robot Model ********************  -->
  <param name="robot_description" command="$(find xacro)/xacro --inorder $(arg model)" />

  <!--  ******************** Joint State Publisher ********************  -->
  <node name="joint_state_publisher" pkg="joint_state_publisher" type="joint_state_publisher" />

  <!--  ******************** Robot State Publisher ********************  -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher" />

  <!--  ******************** Rviz ********************  -->
  <node name="rviz" pkg="rviz" type="rviz" required="true" />

</launch>