Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I think it is because amcl is still looking relative to the namespace for the map (because it is using the service "static_map" per default). Try adding either <param name="use_map_topic" value="true"/> or <remap from="static_map" to="/static_map" />to the amcl.launch file, depending on which method for getting the map you want to use. The /map topic is only used when the "use_map_topic" parameter is true. You can see more here: http://wiki.ros.org/amcl