Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Your _odom_frame parameter should actually be _odom_frame_id and you are missing the base_frame_id parameter, i.e., i think that your rosrun command should look like this:

rosrun amcl amcl scan:=/pioneer/front_laser _odom_frame_id:=amazon_warehouse_robot/odom _base_frame_id:=amazon_warehouse_robot/base

Please re-check the frame names. You can check that the AMCL parameters have been set correctly with rosparam get /amcl/odom_frame_id and rosparam get /amcl/base_frame_id.

Your _odom_frame parameter should actually be _odom_frame_id and you are missing the base_frame_id_base_frame_id parameter, i.e., i think that your rosrun command should look like this:

rosrun amcl amcl scan:=/pioneer/front_laser _odom_frame_id:=amazon_warehouse_robot/odom _base_frame_id:=amazon_warehouse_robot/base

Please re-check the frame names. You can check that the AMCL parameters have been set correctly with rosparam get /amcl/odom_frame_id and rosparam get /amcl/base_frame_id.

Your _odom_frame parameter should actually be _odom_frame_id and you are missing the _base_frame_id parameter, i.e., i think that your rosrun command should look like this:

rosrun amcl amcl scan:=/pioneer/front_laser scan:=amazon_warehouse_robot/laser/scan _odom_frame_id:=amazon_warehouse_robot/odom _base_frame_id:=amazon_warehouse_robot/base

Please re-check the frame names. You can check that the AMCL parameters have been set correctly with rosparam get /amcl/odom_frame_id and rosparam get /amcl/base_frame_id.