Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

It looks like you're seeing this issue, and the fix is in the process of being released.

The opensplice packages can be temporarily removed using dpkg.

sudo dpkg --remove --force-depends ros-dashing-rmw-opensplice-cpp ros-dashing-rosidl-typesupport-opensplice-cpp ros-dashing-rosidl-typesupport-opensplice-c

Before you upgrade or install other packages you'll want to reinstall the opensplice packages that were force uninstalled using

sudo apt-get install --fix-broken