Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I've been able to resolve this issue on my own. My end goal has been to build a Linorobot (www.linorobot.org) But, never having built a robot and being a complete newbie to ROS, I first went through all the beginner tutorials in ROS.org and then started going through the pdf book, ROS_by_example_v1. It recommends the tf and actionlib tutorials in addition to the ROS beginner ones. As a result of these tutorials, I have within my ~/catkin_ws/src folder three packages; beginner_tutorials, learning_tf2 & actionlib_tutorials. With all three packages in the src file, when I run catkin_make, the issue described in my original post occurs. However, if I remove the learning_tf2 package and run catkin_make again, everything works; fibonacci_server.cpp is compiled and linked and rosrun actionlib_tutorials fibonacci_server does invoke the server!

The issue is that when catkin_make processes the catkin package learning_tf2 (in the case of that also being in the src file), it throws an error relating to turtlesim. It then continues on and processes actionlib_tutorials but does not compile fibonacci_server.cpp nor does it make the .h include files associated with the action messages. Removing learning_tf2 from the src file, or fixing the dependency issue for turlesim, allows catkin_make to finish without errors (but still with a few warnings) and for the .cpp file to be compiled.

Thanks to those who tried to help solve this problem.

Onward.

Ray