Ask Your Question

Revision history [back]

Hello, I have installed the ROS2 along with the ROS1 melodic (18.04). It doesn't give any conflict with ROS1.

Actually, there is bridge between ros1 and ros2. I suggest you install the ROS2 using Debian package instead of binary installation. please visit this page and follow the step mentioned above.

Note: There can be the conflict of workspace sourcing after the installation. to avoid this conflict you can use the different workspace where ROS1 is not sourced.

Focus on the Sourcing the setup script part of the provided link

Hello, I have installed the ROS2 along with the ROS1 melodic (18.04). It doesn't give any conflict with ROS1.

Actually, there is bridge between ros1 and ros2. I suggest you install the ROS2 using Debian package instead of binary installation. please visit this page and follow the step mentioned above. there.

Note: There can be the conflict of workspace sourcing after the installation. to avoid this conflict you can use the different workspace where ROS1 is not sourced.

Focus on the Sourcing the setup script part of the provided link