Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Looks like catkin now ignores AMENT_IGNORE, and the holdover AMENT_IGNOREs from codebot are now effecting the build. This PR fixes the issue, as when I run the command from the install page using the new branch when rebuilding the dockerfile, the sample command from the readme continues to works: https://github.com/ros/ros_comm/pull/1465

Alternately, you could remove them while building the dockerfile like so, by adding the last line.

# download sourcecode for sros
RUN rosinstall_generator \
      ros_comm \
      rospy_tutorials \
      --rosdistro ${ROS_DISTRO} \
      --deps \
      --tar > ${ROS_DISTRO}-ros_comm-wet.rosinstall && \
    wstool init -j8 . ${ROS_DISTRO}-ros_comm-wet.rosinstall && \
    rm -rf ros_comm && \
    git clone -b sros https://github.com/ros/ros_comm && \
    git clone -b sros https://github.com/ros-infrastructure/rospkg ../rospkg && \
    find ./ros_comm -name "AMENT_IGNORE" -print0 | xargs -0 rm -rf

As the original dev for SROS1, I haven't worked on this for some time. No surprise evolving dependencies and time would have broken things. Perhaps when I get some more time I'll refactor my original changes to ROS1 Melodic, and try and take a more modular approach to plugins using entry points. There has been some work from Bernhard Dieber et. al. in porting TLS support for roscpp that would be nice to incorporate as well to gain both rospy and roscpp support.

If your still currently evaluating different security concepts for ROS1, I might suggest looking through the book chapter SROS1: Using and Developing Secure ROS1 Systems from Robot Operating System (ROS) The Complete Reference (Volume 3), including the other cited works therein.

SROS2 however is the future, and thus receiving a lot more current development. There will be a SROS2 tutorial at IROS 2018 that I might also suggest for those interested. Complete tutorial materials should be posted on the events web site soon: https://ruffsl.github.io/IROS2018_SROS2_Tutorial/