Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The rosdep install step would install python 2 versions of the package since that's how the dependencies are defined. Instead of hunting down the list of dependencies and installing python 3 version of each, it might be easier to just start building and install the missing python 3 package if there is an error. You will need to set the env variable ROS_PYTHON_VERSION to 3 when building to force python 3 otherwise by default it picks python 2.

Also if you just want basic functionality, you probably want to use the ROS-Comm build as described on the Installation page.