Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Your problem might be that you now have two parents for "base_link" in your tf tree, "odom" and "odom_combined".

robot_pose_ekf has two outputs, the published topic "odom_combined" and the tf transform:

  1. The tf transform looks misconfigured in your launch file, you have set output_frame to "odom_combined" which does not exist in your tf tree. Note: output_frame is not the name of the published odometry topic, but the name of your odometry frame, see rep 105. So you should set output_frame to "odom". Since you can have only one publisher for this transform, this implies that you disable your previous publisher of the odom->base_link transform which is "diff_tf" in your tf tree.

  2. Finally if you have any node that subscribes to /odom you might want it to subscribe to /robot_pose_ekf/odom_combined instead.