Ask Your Question

Revision history [back]

It's doable, but pretty disgusting (macros/pragmas are very involved, due to major difference in the wrapper API). I wouldn't bother with the python 2/3 backwards compatibility, just stick with 3 if you wrote it in 3. Mixing python versions in ROS gets messy very quickly.