Ask Your Question

Revision history [back]

First, make sure you turn off debug mode. That will do unpleasant things to your hard drive and CPU usage. :)

Second, you have two_d_mode turned off, but aren't measuring Z with any sensor. If you are running in 3D mode, you need to make sure that every single pose variable is either being measured directly (preferred) or its velocity is being measured. What's happening in your case is that you have nothing measuring Z, so the Z covariance is exploding. When you start to give the filter measurements for correlated variables (in this case, pitch data), it will affect Z.

Since your robot presumably can't fly, I would recommend fusing Z velocity from your odom0 source (though if you do that, please make sure the Z covariance in the odom0 message is not something massive like 99999).

First, make sure you turn off debug mode. That will do unpleasant things to your hard drive and CPU usage. :)

Second, you have two_d_mode turned off, but aren't measuring Z with any sensor. If you are running in 3D mode, you need to make sure that every single pose variable is either being measured directly (preferred) or its velocity is being measured. What's happening in your case is that you have nothing measuring Z, so the Z covariance is exploding. When you start to give the filter measurements for correlated variables (in this case, pitch data), it will affect Z.Z.

Since your robot presumably can't fly, I would recommend fusing Z velocity from your odom0 source (though if you do that, please make sure the Z covariance in the odom0 message is not something massive like 99999).