Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I think you will have to change the odom topic in the launch file to :

  <param name="odom0" value="/fake_odom"/>

Else the robot_localization node will still be subscribing to the topic /odom which is not what you want.

Also since you are not fusing the output with a gps , the world_frame parameter should be odom

<param name="world_frame" value="map"/>