Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

That ldd output does not look good. To the best of my knowledge binaries should never link against both Qt4 and Qt5. Most likely some dependency of the setup assistant links against one of them and the setup assistant against the other. There is some logic in place in the CMakeLists.txt of the setup assistant that should make the setup assistant use the version of qt that rviz uses.

The question is which one do you want and which package violates your decision. You could work your way with ldd through the libraries the setup assistant binary links and/or look at the cmake output during the build of your workspace to see if something picks up the wrong one.