Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Try turn off the robot model (show footprint instead) and turn on the frontiers (point cloud) in rviz.
And observe how the explore algorithm discover and choose the frontiers.
There are three parameter about how to choose frontier as a goal to navigation. (closet, middle, centroid).

the error message is about the base_local_planner can not find the target cells,
try to git clone the navigation code and check how to adjust the planner parameters.

Hope this can help. :)