Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Your problem might be related to this issue (although the error message is slightly different): https://github.com/ros-drivers/rosserial/issues/177

I am encountering this problem with ubuntu 14.04 and different kernel versions (3.10.96, 3.13.0, 3.16.0).

I found three possible workarounds:

  • Use the current xenial kernel (version 4.4.0) with ubuntu 14.04 (DISCLAIMER: This is a serious change in your system and might cause trouble such as driver incompatibilities)
  • Start the serial_node with baud rate 0, exit and restart the serial node with the correct baud rate. You have to repeat this every time the error occurs.
  • Modify SerialClient.py according to the suggestion of kvogt

Your problem might be related to this issue (although the error message is slightly different): https://github.com/ros-drivers/rosserial/issues/177

I am encountering this problem with ubuntu 14.04 and different kernel versions (3.10.96, 3.13.0, 3.16.0).

I found three possible workarounds:

  • Use the current xenial kernel (version 4.4.0) with ubuntu 14.04 (DISCLAIMER: This is a serious change in your system and might cause trouble such as driver incompatibilities)
  • Start the serial_node with baud rate 0, exit and restart the serial node with the correct baud rate. You have to repeat this every time the error occurs.
  • Modify SerialClient.py according to the suggestion of kvogt

Your problem might be related to this issue (although the error message is slightly different): issue: https://github.com/ros-drivers/rosserial/issues/177

I am encountering this problem with ubuntu 14.04 and different kernel versions (3.10.96, 3.13.0, 3.16.0).

I found three possible workarounds:

  • Use the current xenial kernel (version 4.4.0) with ubuntu 14.04 (DISCLAIMER: This is a serious change in your system and might cause trouble such as driver incompatibilities)
  • Start the serial_node with baud rate 0, exit and restart the serial node with the correct baud rate. You have to repeat this every time the error occurs.
  • Modify SerialClient.py according to the suggestion of kvogt

Your problem might be related to this issue: https://github.com/ros-drivers/rosserial/issues/177Maybe my answer here can help you: http://answers.ros.org/question/210875/arduino-rosserial-unable-to-sync-with-device/?answer=237868#post-id-237868

I am encountering this problem with ubuntu 14.04 and different kernel versions (3.10.96, 3.13.0, 3.16.0).

I found three possible workarounds:

  • Use the current xenial kernel (version 4.4.0) with ubuntu 14.04 (DISCLAIMER: This is a serious change in your system and might cause trouble such as driver incompatibilities)
  • Start the serial_node with baud rate 0, exit and restart the serial node with the correct baud rate. You have to repeat this every time the error occurs.
  • Modify SerialClient.py according to the suggestion of kvogt