ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question

Revision history [back]

I'm not sure what's causing your trouble, as I don't really see anything wrong with the data. However, you may want to look into the following:

  1. Since all your high-frequency data appears to fall victim to decreased frequency when bagging, can you try bagging to another disk? It seems like very strange behavior to me, and unrelated to r_l.
  2. Can you run top or htop to see if something is consuming a lot of CPU? Also, let me know how much CPU r_l is using.
  3. I noticed in your config file that the debug flag and corresponding path are specified, although I recognize that debug is set to false. Just an FYI: if you're running live and turn on debug mode, it's going to eat a lot of CPU and slow down the filter.
  4. Are you running from binaries? If so, which version? If you're running from source, which version, and did you build in release mode?