Ask Your Question

Revision history [back]

Assuming you launch the openn_launch without throttling parameters on the same machine as rgbd_demo, my best guess would be that your computer is too slow to reproject the point clouds with more than 15 hz.

In that case, one of your cpus should be near 100% while running rgbd_demo.

Since you have exactly 15Hz (i.e. exactly half of the maximum), you might also have enabled some throttling parameter. Maybe you can configure them differently in the openni_launch launch-file or use dynamic_reconfigure to set it.

Assuming you launch the openn_launch without throttling parameters on the same machine as rgbd_demo, my best guess would be that your computer is too slow to reproject the point clouds with more than 15 hz.

In that case, one of your cpus should be near 100% while running rgbd_demo.

Since you have exactly 15Hz (i.e. exactly half of the maximum), you might also have enabled some throttling parameter. Maybe you can configure them differently in the openni_launch launch-file or use dynamic_reconfigure to set it.

Edit: Try increasing the subscriber queue size for each message_filters::Subscriber (in lines 90 to 93). 2 should be sufficient, but 5 won't hurt either.