Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi,

Thank you for your response. I tried getting the map with the update you suggested but still I am not getting the map.

You are correct that my bagfile does not have any tf messages (its because I am only using LIDAR). So, to overcome this, I tried using static_transform_publisher identity as follows in my mapping_default.launch file:

<node pkg="tf" type="static_transform_publisher" name="baseFrame_to_laser_broadcaster" args="0 0 0 0 0 0 base_frame laser 10"/>

However, I am getting the error: "lookupTransform base_footprint to laser timed out. Could not transform laser scan into base_frame." in the terminal in which I am running roslaunch hector_slam_launch tutorial.launch.

Also, in my RViz I am getting the error: "No tf data. Actual error: Fixed Frame [map] does not exist."

I have removed the "rosrun tf static_transform_publisher 0.0 0.0 0.0 0 0 0 1 map my_frame 100" as suggested by you.

Please direct me what else is needed to be changed?

Regards, Shantnu Kakkar