Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

It is rviz that causes the problem, not the teleop. What you saw on the rosout is just a warning for teleop node. I suggest you to:

  1. Disable the launch of rviz (maybe launch it manually via another launch file) to reduce confusion while you are reading rosout.
  2. Enable output to screen for teleop to see the instruction of how to use it:

<node pkg="teleop_twist_keyboard" type="teleop_twist_keyboard.py" name="teleop" output="screen"/>