Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi,

When the generated clouds are empty, it may because the intrinsic parameters (focals) of camera_info are wrong or the depth image format is not standard (rtabmap wants 16bits unsigned short = mm or 32bits float = meters). For example, if you have distance in mm in float format, the point cloud will be 1000x bigger. By default, cloud_max_depth is 4 meters. You could try to set cloud_max_depth to 0 to see if the clouds can be generated (even if the calibration is wrong).

cheers

Hi,

When the generated clouds are empty, it may because the intrinsic parameters (focals) of camera_info are wrong or the depth image format is not standard (rtabmap wants 16bits unsigned short = mm or 32bits float = meters). For example, if you have distance in mm in float format, the point cloud will be 1000x bigger. By default, cloud_max_depth is 4 meters. meters (thus filtering all points of the previous case). You could try to set cloud_max_depth to 0 to see if the clouds can be generated (even if the calibration is wrong).

cheers

Hi,

When the generated clouds are empty, it may because the intrinsic parameters (focals) of camera_info are wrong or the depth image format is not standard (rtabmap wants 16bits unsigned short = mm or 32bits float = meters). For example, if you have distance in mm in float format, the point cloud will be 1000x bigger. By default, cloud_max_depth is 4 meters (thus filtering all points of the previous case). You could try to set cloud_max_depth to 0 (filtering disabled) to see if the clouds can be generated (even if the calibration is wrong).

cheers

Hi,

When the generated clouds are empty, it may because the intrinsic parameters (focals) of camera_info are wrong or the depth image format is not standard (rtabmap wants 16bits unsigned short = mm or 32bits float = meters). For example, if you have distance in mm in float format, the point cloud will be 1000x bigger. By default, cloud_max_depth is 4 meters (thus filtering all points of the previous case). You could try to set cloud_max_depth to 0 (filtering disabled) to see if the clouds can be generated (even if the calibration is wrong).

EDIT1: In rtabmapviz, the maximum depth parameter for the map is under Preferences->3D Rendering.

EDIT2: You may debug the depth image scale by showing the cloud using DepthCloud display in RVIZ instead of PointCloud2.

cheers

Hi,

When the generated clouds are empty, it may because the intrinsic parameters (focals) of camera_info are wrong or the depth image format is not standard (rtabmap wants 16bits unsigned short = mm or 32bits float = meters). For example, if you have distance in mm in float format, the point cloud will be 1000x bigger. By default, cloud_max_depth is 4 meters (thus filtering all points of the previous case). You could try to set cloud_max_depth to 0 (filtering disabled) to see if the clouds can be generated (even if the calibration is wrong).

EDIT1: In rtabmapviz, the maximum depth parameter for the map is under Preferences->3D Rendering.

EDIT2: You may debug the depth image scale by showing the cloud using DepthCloud display in RVIZ instead of PointCloud2.

EDIT3: The database contains a map, though the depth image is not registered with the RGB image (see image below). The depth scale is large (like between 10 meters to ~40 meters). The calibration looks ok though (640x480 fx=617.326 fy=617.326 cx=321.177 cy=245.512). image description

cheers