Ask Your Question

Revision history [back]

Try setting

holonomic_robot: false

in your yaml file.

Try setting

holonomic_robot: false

in your yaml file.

Update:

Yes you are right, I missed that point. But now looking to your YAML file, there seems an indentation problem if this is exactly the same indentation your yaml file has. YAML is indentation sensitive. Therefore your parameters may not be evaluated in DWAPlannerROS namespace. Try correcting it as;

DWAPlannerROS:
  max_trans_vel: 0.8       
  min_trans_vel: 0.05      

  max_vel_x: 0.2      
  min_vel_x: 0.05  

  max_vel_y: 0 
  min_vel_y: 0

Also you can check these parameter values from parameter server to be sure that they are set correctly.