Ask Your Question

Revision history [back]

So..rosserial_arduino was always setting the baud rate of arduino as 57600. So, for rosserial_python, only the baud rate of 57600 was working.I made rosserial_arduino run at the baud rate of 9600 (or 19200, etc.) by editing ArduinoHardware.h in <sketchbook>/libraries/ros_lib and then specified the same baud rate for rosserial_python and it is working now.
Just make sure to change the baud rates for both rosserial_arduino and rosserial_python if you want to use a non-default baud rate.

So..rosserial_arduino was always setting the baud rate of arduino as 57600. So, for rosserial_python, only the baud rate of 57600 was working.I made rosserial_arduino run at the baud rate of 9600 (or 19200, etc.) by editing ArduinoHardware.h ArduinoHardware.h in <sketchbook>/libraries/ros_lib <sketchbook>/libraries/ros_lib and then specified the same baud rate for rosserial_python and it is working now.
Just make sure to change the baud rates for both rosserial_arduino and rosserial_python if you want to use a non-default baud rate.