Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

According to this post on ros-users, you have to start rosbag with the --clock argument for use_sim_time to work properly with static_transform_publisher (and probably other nodes as well):

The output of roswtf reported the following:

"ERROR /use_simtime is set but no publisher of /clock is present"

Setting use_simtime to true and playing the bag with the --clock option resolved all issues.

You will probably see the same output if you start your launchfile and then run roswtf.