Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hi,

For your problem I think you should try: /camera/rgb/image_color

/camera/rgb/image_raw and /camera/rgb/image_rect will give you grayscale image.

Am trying to do the same thing but struggling to get data from kinect. Since it is question regarding same topic..I did not create a new post. Here is what am doing, if you see something missing please let me know:

  1. In terminal (using ros-groovy):

    roslaunch openni_launch openi.launch
    
  2. In Matlab:

    node = rosmatlab.node('NODE',master_uri)
    subscriber = rosmatlab.subscriber('/camera/rgb/image_rect','sensor_msgs/Image',10,node);
    imgMsg = rosmatlab.message('sensor_msgs/Image',node);
    
  3. I also tried the way you have mentioned but still no progress. Code does not enter in grabimage function.:(

    ImgSub.setOnNewMessageListeners({@grabimage});
    

It can be seen with rostopic info that NODE is subscribed to topic /camera/rb/image_rect but imgMsg.getData() is always zero.

Could you please tell if am missing any steps.

Thanks..:)

Hi,

For your problem I think you should try: /camera/rgb/image_color

/camera/rgb/image_raw and /camera/rgb/image_rect will give you grayscale image.

Am trying to do the same thing but struggling to get data from kinect. Since it is question regarding same topic..I did not create a new post. Here is what am doing, if you see something missing please let me know:

  1. In terminal (using ros-groovy):

    roslaunch openni_launch openi.launch
    
  2. In Matlab:

    node = rosmatlab.node('NODE',master_uri)
    subscriber = rosmatlab.subscriber('/camera/rgb/image_rect','sensor_msgs/Image',10,node);
    imgMsg = rosmatlab.message('sensor_msgs/Image',node);
    
  3. I also tried the way you have mentioned but still no progress. Code does not enter in grabimage function.:(

    ImgSub.setOnNewMessageListeners({@grabimage});
    

It can be seen with rostopic info that NODE is subscribed to topic /camera/rb/image_rect but imgMsg.getData() is always zero.

Could you please tell if am missing any steps.

Thanks..:)