Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

This is a communication problem. When you create your NodeConfiguration, you pass the IP of the master as your local node IP. You should set host to 192.168.0.68, or have you code figure it out dynamically. See: http://www.ros.org/wiki/rosjava/Overview/Nodes#NodeConfiguration

This is a communication problem. When you create your NodeConfiguration, you pass the IP of the master as your local node IP. You should set host to 192.168.0.68, or have you code figure it out dynamically. See: http://www.ros.org/wiki/rosjava/Overview/Nodes#NodeConfiguration

EDIT: This could also be a problem with the windows firewall blocking inbound or outbound ROS connections. Since ROS listens on dynamic ports, and connections are made in both directions, the only real solution is to disable the firewall entirely.