Ask Your Question

Revision history [back]

If you installed from debians (sudo apt-get install ....) then the files are in /opt/ros/.. which is a protected directory. You probably need to use "sudo" in front of your chmod/chown commands (which executes that one command as superuser, after possibly prompting for your password).

Now, be aware that the changes will be overwritten when you next update your installation. Therefore, a better solution is probably to copy the launch file into a local working directory in which you do have permissions and modify the setup there -- or create a new launch file altogether that just sets your port parameter for the turtlebot driver.

Note: you should never run a "rosrun" or "roslaunch" command with sudo as your superuser account is probably not set up for ROS, and many other bad things could happen.