Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Update:

Now I can see the image from the camera display by adding the topic /camera/rgb/image_color topic to rviz using openni_launch openni.launch which I couldn't do before. However, the topics regarding point cloud 2 display don't ever get published.

Update:

Now I can see the image from the camera display by adding the topic /camera/rgb/image_color topic to rviz using openni_launch openni.launch which I couldn't do before. However, the topics regarding point cloud 2 display don't ever get published.

Second Update: The point cloud2 display has started working. I don't know how (maybe it was the ros updates that I did yesterday), but I consistently can get them to display except now, rviz freezes and I get the following error repeatedly:

Image messages received:      0
CameraInfo messages received: 84
Synchronized pairs:           0
Image messages received:      0
CameraInfo messages received: 92
Synchronized pairs:           0

Update:

Now I can see the image from the camera display by adding the topic /camera/rgb/image_color topic to rviz using openni_launch openni.launch which I couldn't do before. However, the topics regarding point cloud 2 display don't ever get published.

Second Update: The point cloud2 display has started working. I don't know how (maybe it was the ros updates that I did yesterday), but I consistently can get them to display except now, rviz freezes and I get the following error repeatedly:repeatedly

Image messages received:      0
CameraInfo messages received: 84
Synchronized pairs:           0
Image messages received:      0
CameraInfo messages received: 92
Synchronized pairs:           0