Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Take a look at this:

First of all ensure that you can ping each host from the other host. In order to communicate, one of the hosts must be running roscore, and the other one must have set ROS_MASTER_URI to use the other host's roscore.

For instance, export ROS_MASTER_URI=http://host-s:11311 must be set on host-p.

If this doesn't solve it, I've had success on similar situations by setting ROS_IP or ROS_HOST variables.