Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The source installation of ROS will compile with other versions of boost, but due to the possibility of binary incompatibility, the binary versions of ROS must be installed with the same version of boost that they were built with.

If you'd like to use ROS with a version of boost other than the standard version, you'll have to build ROS from source.