Ask Your Question

Revision history [back]

Your description and error output say two completely different things. Judging from the output transform_broadcaster.h can't be found, for that you need to depend on tf package. When you add that dependency to your manifest it should compile, provided there are no other errors.

Your description and error output say two completely different things. Judging from the output transform_broadcaster.h can't be found, for that you need to depend on tf package. When you add that dependency to your manifest it should compile, provided there are no other errors.

tf/frames.hpp include file does not exist, you probably meant kdl/frames.hpp.

To use Xn* headers you need to depend on nite and openni packages.

Your description and error output say two completely different things. Judging from the output transform_broadcaster.h can't be found, for that you need to depend on tf package. When you add that dependency to your manifest it should compile, provided there are no other errors.

<depend package="tf"/>

tf/frames.hpp include file does not exist, you probably meant kdl/frames.hpp.

<depend package="kdl"/>

To use Xn* headers you need to depend on nite and openni packages.

<depend package="nite"/>
<depend package="openni"/>