Ask Your Question

Revision history [back]

The root problem here is that the Debian packages were automatically compiled with support for SSE3 (since the build farm machines do support SSE3), but the target machine doesn't support SSE3.

To fix this, you will have to overlay the offending stacks using the rosinstall tool or by checking them out from source onto your ROS_PACKAGE_PATH. Note that if you check them out onto your ROS_PACKAGE_PATH, the location of these new stacks must be ahead of the existing installation in /opt/ros so that rospack uses these overlaid versions. Run a rosmake --pre-clean after installation to ensure that all dependencies that you have checked out are rebuilt with the correct instructions for your environment. Also make sure to recompile any of your own packages that depend on the offending stacks, as they will need to be linked against the new overlaid packages instead of the existing SSE3 enabled versions in /opt/ros.