Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

answered 2011-03-05 00:29:01 -0600

joq gravatar image

Make sure that /dev/ttyUSB0 is the correct port for your device:

$ dmesg | grep tty

If using a different serial port, set the ~port parameter appropriately:

$ rosrun sicktoolbox_wrapper sicklms _port:=/dev/XXX _baud:=38400

If the port was correct, check that you are using the right kind of serial cable, have valid permissions, etc.