Ask Your Question

Revision history [back]

First off, the move_base_stage package is deprecated. You should look into the navigation_stage package for newer example launch files.

Now, for your actual problem. That world file in the tutorial is likely an old, out of date World file format. To fix this, try running the upgrade-world.sh file available in the stage package. For example, rosrun stage upgrade-world.sh willow.world willow-new.world and then try using willow-new.world instead of willow.world.

First off, the move_base_stage package is deprecated. You should look into the navigation_stage package for newer example launch files.

Now, for your actual problem. That world file in the tutorial is likely an old, out of date World file format. To fix this, try running the upgrade-world.sh file available in the stage package. For example,

rosrun stage upgrade-world.sh willow.world willow-new.worldwillow-new.world
 

and then try using willow-new.world instead of willow.world.