Ask Your Question

Revision history [back]

After much Googling about Glut and CMake, I finally found the magic fix. Turns out I need the following depends in my package.xml file:

<build_depend>glut</build_depend>
<build_depend>libxmu-dev</build_depend>
<build_depend>libxi-dev</build_depend>

And the following in my CMakeLists.txt file:

find_package(GLUT REQUIRED)

This combination resulted in a successful build on Jenkins.

--patrick