Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

There is a problem with depth_registration topic. For using kinect as a laser for autonomous exploration application, you just need depth data.

To solve the above problem, you need to change the parameter depth_registration to false in the openni.launch file. I use ROS fuerte, in my system this file "openni.launch" is found at /opt/ros/fuerte/stacks/openni_launch/launch$. Check correspondingly for your system.

Thank you

There is a problem with depth_registration topic. For using kinect as a laser for autonomous exploration application, you just need depth data.

To solve the above problem, you need to change the parameter depth_registration to false in the openni.launch file. I use ROS fuerte, in my system this file "openni.launch" is found at /opt/ros/fuerte/stacks/openni_launch/launch$. Check correspondingly for your system.

If this is not working for you. Change the parameter depth_registration to false in the kinect.launch file also and launch kinect.launch separately.

Thank you