Ask Your Question
1

broken dependencies in fuerte on Ubuntu 12.04

asked 2012-06-04 08:49:32 -0500

somudrog gravatar image

Hi,

I'm trying to install ros-fuerte-arm-navigation in 12.04 but get broken dependencies in image-common, navigation, robot-model, and visualization. The problem seems to be a conflict with oneiric versions of libassimp-dev and yaml.cpp. Here are the messages I get when I run apt-get -f install (to try to fix the broken dependencies):

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libassimp-dev yaml-cpp
The following NEW packages will be installed:
  libassimp-dev yaml-cpp
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
76 not fully installed or removed.
Need to get 0 B/299 kB of archives.
After this operation, 1,052 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 381683 files and directories currently installed.)
Unpacking yaml-cpp (from .../yaml-cpp_0.2.7-5precise-20120502-0513-+0000_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/yaml-cpp_0.2.7-5precise-20120502-0513-+0000_amd64.deb (--unpack):
 trying to overwrite '/usr/include/yaml-cpp/emitter.h', which is also in package yaml-cpp0.2.6-dev 0.2.6-4~oneiric
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Unpacking libassimp-dev (from .../libassimp-dev_2.0.863+dfsg-2_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb (--unpack):
 trying to overwrite '/usr/include/assimp/aiQuaternion.h', which is also in package assimp-dev 2.0.0.7-ubuntu1~oneiric1
Errors were encountered while processing:
 /var/cache/apt/archives/yaml-cpp_0.2.7-5precise-20120502-0513-+0000_amd64.deb
 /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I try to remove the oneiric versions of assimp-dev or yaml-cpp in Synaptic, then a bunch of other packages in both electric and fuerte get marked for removal. Any idea how to fix this?

Thanks!

edit retag flag offensive close delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2012-06-04 08:58:27 -0500

Unfortunately, I don't know exactly what the root of the broken deps are, but a few people I know have had the exact same problem.

Either way, the tool I relied on at first was aptitude instead of apt-get, aptitude does a better job dealing with dependencies.

Also, I believe I had to first remove fuerte, then remove/reinstall yaml-cpp and libassimp-dev, then re-install fuerte.

Good luck

edit flag offensive delete publish link more

Comments

It looks like you have upgraded from oneiric and there's old conflicting packages still installed. You'll need to clean them up manually.

tfoote ( 2012-06-21 21:21:35 -0500 )edit

Yes the upgrade apparently caused some problems. I'm usually hesitant about manual re-configuration possibly leading down the rabbit hole, but in this case it was enough just to fix the two packages I mentioned.

phil0stine ( 2012-06-25 05:54:04 -0500 )edit
1

answered 2012-08-14 07:11:24 -0500

FabricioFC gravatar image

I got the same problem here and I fixed with:

dpkg -i --force-overwrite /var/cache/apt/archives/yaml-cpp_0.2.7-5precise-20120502-0513-+0000_amd64.deb 
dpkg -i --force-overwrite /var/cache/apt/archives/libassimp-dev_2.0.863+dfsg-2_amd64.deb

I was really worried about this solution, because I don't like to force things like that, but it is working now.

edit flag offensive delete publish link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2012-06-04 08:49:32 -0500

Seen: 1,828 times

Last updated: Aug 14 '12