Ask Your Question
0

Getting rid of hddtemp prompt

asked 2014-08-22 23:01:59 -0500

bjem85 gravatar image

Is there any option to get rid of the hddtemp prompt or automate the response?

I followed the standard ROS hydro installation instructions and ran sudo apt-get install ros-hydro-desktop-full, and the hddtemp prompt comes up. Is there a standard way to automatically answer no to this question so that I don't have to 'babysit' every computer that I install ROS on?

Thanks, Bart

edit retag flag offensive close merge delete

Comments

This isn't really ros-related; that prompt is coming from the hdtemp package. You may want to consult the dpkg and apt manuals or ask on a Debian or Ubuntu forum.

ahendrix gravatar imageahendrix ( 2014-08-23 00:06:33 -0500 )edit

That said, I remember being able to do this when I built the PR2 installer, but I don't remember the esoteric invocation that I needed to make it work properly, and I don't remember if it was something that I set in the preseed file or some other way.

ahendrix gravatar imageahendrix ( 2014-08-23 02:39:01 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-08-26 05:01:06 -0500

bjem85 gravatar image

updated 2014-09-04 03:56:23 -0500

The answer (ironically) is on the ROS PR2 installation page. It is to do with the Ubuntu package installation. The command is:

echo "hddtemp hddtemp/daemon boolean false" | sudo debconf-set-selections

See the page for full context.

I am in two minds. It's not a ROS problem in the sense that it's not a ROS package that is interrupting the automated setup process, on the other hand it is a ROS problem because it affects a ROS.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-22 23:01:59 -0500

Seen: 74 times

Last updated: Sep 04 '14