Ask Your Question
0

Unmet dependencies with unstable-desktop-full, Natty

asked 2012-01-25 15:45:30 -0500

CaptainTrunky gravatar image

updated 2012-01-25 16:40:45 -0500

Hi! I try to install ros-unstable-desktop-full on Natty 11.04, but I have next problem:

~$ sudo apt-get install ros-unstable-desktop-full
...
The following packages have unmet dependencies:
 ros-unstable-desktop-full : Depends: ros-unstable-vision-opencv (= 1.6.1-s1313731650~natty) but it is not going to be installed
                             Depends: ros-unstable-image-pipeline (= 1.5.2-s1313739013~natty) but it is not going to be installed
                             Depends: ros-unstable-image-transport-plugins (= 1.4.1-s1313731752~natty) but it is not going to be installed
E: Broken packages
~$ sudo apt-get install ros-unstable-vision-opencv
...
The following packages have unmet dependencies:
 ros-unstable-vision-opencv : Depends: libopencv2.3-dev (= 2.3.1+svn6514+branch23-1~natty) but it is not going to be installed
E: Broken packages

There was ros-electric previously, but I removed it completely. How can I fix this problem? Thanks in advance!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2012-01-25 16:59:18 -0500

ahendrix gravatar image

Unstable is unstable; it is not guaranteed to work.

If you want the latest builds, you should look at the ros-shadow-fixed repository. It has more recent builds of things, but is even more likely to be broken.

edit flag offensive delete link more

Comments

I met this problem 2 month ago, so, problem can be on my side. Thanks for reply. CaptainTrunky ( 2012-01-25 19:56:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2012-01-25 15:45:30 -0500

Seen: 204 times

Last updated: Jan 25 '12