Ask Your Question

Troubles with rxgraph, rxplot, and rxbag on OSX with Homebrew and Electric.

asked 2012-01-12 07:46:21 -0600

ptf gravatar image

Hi All, I followed the installation instructions for OSX (Lion) using Homebrew and many things are working great. However, I'm unable to get rxgraph, rxplot, or rxbag to work.


ROS Electric

OSX Lion

Python 2.7.1 (r271:86832, Jul 31 2011, 19:30:53) [GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on darwin


rxgraph fails because the python gobject library is missing:

  Traceback (most recent call last):
  File "/Users/ptf/Work/ethz/vc_ros/ros/bin/rxgraph", line 35, in <module>
    import rxgraph
  File "/Users/ptf/Work/ethz/vc_ros/rx/rxgraph/src/rxgraph/", line 37, in <module>
    import rxgraph.impl
  File "/Users/ptf/Work/ethz/vc_ros/rx/rxgraph/src/rxgraph/", line 46, in <module>
    from rxgraph.viewer import RxGraphViewerFrame
  File "/Users/ptf/Work/ethz/vc_ros/rx/rxgraph/src/rxgraph/", line 34, in <module>
    import xdot
  File "/Users/ptf/Work/ethz/vc_ros/rx/xdot/src/xdot/", line 2, in <module>
    import wxxdot
  File "/Users/ptf/Work/ethz/vc_ros/rx/xdot/src/xdot/", line 22, in <module>
    from xdot import *
  File "/Users/ptf/Work/ethz/vc_ros/rx/xdot/src/xdot/", line 34, in <module>
    import gobject
ImportError: No module named gobject


rxplot crashes with a nasty looking error, but this already has an open ticket.


rxbag exits with an informative error message:

> rxbag
This application requires wxPython version 2.8

As far as I can tell, the Homebrew instructions install wxPython 2.9. So, when I change the python code to check for 2.9, it fails downstream when trying to load pycairo:

> rxbag
Traceback (most recent call last):
  File "/Users/ptf/Work/ethz/vc_ros/ros/bin/rxbag", line 38, in <module>
    import rxbag
  File "/Users/ptf/Work/ethz/vc_ros/rx/rxbag/src/rxbag/", line 34, in <module>
    from rxbag_main import rxbag_main
  File "/Users/ptf/Work/ethz/vc_ros/rx/rxbag/src/rxbag/", line 56, in <module>
    import wx.lib.wxcairo
  File "/usr/local/lib/wxPython-", line 54, in <module>
    import cairo
ImportError: No module named cairo

I assume the rxplot problem is a separate issue, but is there something wrong with my Python installation that I am missing cairo and gobject?

Thanks for your help!


edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2012-02-02 11:01:28 -0600

William gravatar image

These packages are known not to work currently due to a problem with gtk. In the mean time, there are some similar tools provided by ros_gui:

That work very well on the Mac.

There are some related tickets open:

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Question Tools


Asked: 2012-01-12 07:46:21 -0600

Seen: 870 times

Last updated: Feb 02 '12