Ask Your Question
1

Error validating server certificate for 'https://code.ros.org:443'

asked 2011-08-30 15:52:18 -0500

Kevin gravatar image

updated 2012-02-19 07:25:56 -0500

I am installing ROS Electric on OSX Lion (10.7) using the commands from the install page

rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=electric&variant=desktop-full&overlay=no"

I keep having to validate the server certificate over and over again. I keep hitting (p) for permanently, but it doesn't seem to remember. How do I fix this? Now, to be clear, I eventually am able to download all of ROS (and with major modifications) get it up and running on OSX Lion. For linux there is a command to get and update keys:

wget http://packages.ros.org/ros.key -O - | sudo apt-key add -

What is the equivalent command for OSX (using key chains I assume) to avoid the following error?

Error validating server certificate for 'https://code.ros.org:443':
 - The certificate is not issued by a trusted authority. Use the
   fingerprint to validate the certificate manually!
Certificate information:
 - Hostname: *.ros.org
 - Valid: from Thu, 10 Sep 2009 23:16:35 GMT until Wed, 12 Sep 2012 05:05:53 GMT
 - Issuer: Equifax Secure Certificate Authority, Equifax, US
 - Fingerprint: fb:45:70:74:bf:12:94:01:05:23:8d:ee:b2:04:66:d0:f8:9a:e8:d2
(R)eject, accept (t)emporarily or accept (p)ermanently?
edit retag flag offensive close delete

Comments

Which variant of ROS are you trying to install, and which commands are you running to install it? Can you tell which part of the install is failing, or maybe post a few lines above that error? ahendrix ( 2011-09-02 12:24:49 -0500 )edit

1 answer

Sort by » oldest newest most voted
2

answered 2011-09-07 16:59:13 -0500

ahendrix gravatar image

I think SVN is trying to cache the server certificate and failing to do so.

It may be trying to cache to the Keychain, in which case you should try unlocking your keychain and doing an 'svn up' in one of stacks that is versioned with svn. Repeated attempts to 'svn up' in the same directory shouldn't ask you to accept the certificate any more.

On the other hand, it may be trying to cache to ~/.subversion/auth/ , in which case you should make sure that directory exists and that your user has write permissions to it. See also: http://www.linxit.de/svnbook/en/1.1/svn-book.html#svn-ch-6-sect-4.3.2

edit flag offensive delete publish link more

Comments

1
Thanks! My ~./subversion was owned by root so I changed ownership to me: sudo chown -R kevin ~./subversion Kevin ( 2011-09-10 03:50:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2011-08-30 15:52:18 -0500

Seen: 1,307 times

Last updated: Sep 07 '11