Ask Your Question
1

TurtleBot unable to contact my own server

asked 2011-08-16 11:28:16 -0500

mmwise gravatar image

updated 2011-08-16 11:59:57 -0500

tfoote gravatar image

A question from Marc Howard:

I am having a problem getting the turtlebot minimal.launch program to run. It gives me the following error:

Unable to contact my own server at [http://IP_OF_LAPTOP:42375/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself. Please check for errors by running:

ping ip_of_laptop

For more tips, please see

http://www.ros.org/wiki/ROS/NetworkSetup

I have checked both .bashrc files and they have the following lines in them:

Laptop .bashrc file:

export ROS_MASTER_URI=http://IP_OF_LAPTOP:11311
export ROS_HOSTNAME=IP_OF_LAPTOP

Workstation .bashrc file:

export ROS_MASTER_URI=http://IP_OF_LAPTOP:11311
export ROS_HOSTNAME=IP_OF_WORKSTATION

I have tried replacing those with the actual IP addresses and that did not work either, and documentation I found on the net advised that the way I have it above was correct. I also don't understand on a fundamental level where it assigns "IP_OF_LAPTOP" or"IP_OF_WORKSTATION" to the actual number.

I went through the NetworkSetup tutorial and the EnvirmonmentVariables turtorial with no luck. My computers also do not have names on the network (aka they cannot be accessed with a URL other than their ip address. Do you have any suggestions? Thank you very much!

edit retag flag offensive close delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2011-08-16 11:45:14 -0500

mmwise gravatar image

In a tutorial when we write something in all caps like IP_OF_LAPTOP, we mean that you should replace IP_OF_LAPTOP with your actual IP. You can find out the IP of a computer in Ubuntu by typing ifconfig in a terminal.

you should see something like:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:88474362 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88474362 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:9302480192 (9.3 GB)  TX bytes:9302480192 (9.3 GB)

wlan0     Link encap:Ethernet  HWaddr 48:5d:60:7d:22:e6  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::4a5d:60ff:fe7d:22e6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1093031 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1422901 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:430045105 (430.0 MB)  TX bytes:1327311556 (1.3 GB)

In this example the IP_OF_LAPTOP is 192.168.1.4

edit flag offensive delete publish link more
0

answered 2011-08-16 12:31:11 -0500

baalexander gravatar image

I had a similar problem where my workstation would not connect to master. My silly issue was because I forgot the http:// before the IP address in ROS_MASTER_URI.

edit flag offensive delete publish link more
0

answered 2012-05-17 12:02:27 -0500

TaylorC gravatar image

updated 2013-07-05 00:47:32 -0500

I am having a similar problem but I have put in the correct addresses (I believe):

Unable to contact my own server at [http://http:10.5.6.187:59339/]. Workstation IP = 10.5.6.93 TB IP = 10.5.6.187

I have dashboard up in Full mode with 0,1,2 all green.

WORKSTATION:~$ echo $ROS_MASTER_URI
http://10.5.6.187:11311
WORKSTATION:~$ echo $ROS_HOSTNAME
10.5.6.93

turtlebot@turtlebot:~$ echo $ROS_MASTER_URI
http://10.5.6.187:11311
turtlebot@turtlebot:~$ echo $ROS_HOSTNAME
http:10.5.6.187

They can ping themselves no problem as well.

edit flag offensive delete publish link more

Comments

1

Well I figured it out. Realized I had accidentally added http: to the turtlebot hostname.

TaylorC ( 2012-05-17 13:09:03 -0500 )edit

I have a similar problem. I redid the echo export commands for both the Host and Master, but it doesn't change the values... I feel like when I use roslaunch turtlebot_dashboard, it's getting these variables from a different file rather than .bashrc...

jprince ( 2013-07-05 00:30:00 -0500 )edit

What do you mean by "it doesn't change the value"? If you do first export, then echo you show see, if the environment variable gets set or not. Further than that, make sure that you do roslaunch in the terminal you set the environment variables in.

bit-pirate ( 2013-07-05 00:50:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2011-08-16 11:28:16 -0500

Seen: 985 times

Last updated: Jul 05 '13