Ask Your Question
0

cannot find roscpp when following tutorial 3

asked 2011-06-13 09:59:04 -0500

surfexceltide gravatar image

updated 2011-06-27 18:25:01 -0500

tfoote gravatar image

hey all, i'm following the ROS tutorial 3 in which it teaches how to create a new package which has dependencies. when i enter the following: $ roscreate-pkg beginner_tutorials roscpp rospy std_msgs terminal shoots back: ERROR: dependency [roscpp] cannot be found

note : i've updated the ROS_PACKAGE_PATH variable. i have verified manually and (with rospack find also) that roscpp actually exists in my filesystem. its just that roscreate cant seem to find it.

any help would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

1
in the terminal you're trying to roscreate-pkg, can you roscd roscpp. If not your package path is not set in that terminal mmwise ( 2011-06-13 12:22:40 -0500 )edit
can you describe your install setup better? i.e. what is your ROS_ROOT, what is your ROS_PACKAGE_PATH, and where is roscpp? can you also verify that you can run "rospack find roscpp", then run the roscreate-pkg command and still get a failure. kwc ( 2011-06-13 13:13:40 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2011-06-20 19:14:24 -0500

I suppose your ROS_PACKAGE_PATH is not set accordingly.

1) Close your terminal and open again which will reload your ~/.ros to default one. 2) Run the following again $ cd ~/ $ mkdir ros_tutorials $ export ROS_PACKAGE_PATH=~/ros_tutorials:$ROS_PACKAGE_PATH

3) To verify whether your PATH set correctly, try 'roscd roscpp'. If it changes to the roscpp folder then path file is set correctly.

4) Now try creating package with dependencies you wish.

Hope this would help you. Note: I am a newbie in ROS, please let me know if there is something wrong.

edit flag offensive delete link more

Comments

thanks! that was precisely the problem. now I directly edit my .bashrc file instead of updating my ROS_PACKAGE_PATH everytime i open a mew terminal. surfexceltide ( 2011-06-22 11:19:05 -0500 )edit
4

answered 2011-06-14 07:37:27 -0500

If you installed diamondback via deb packages, to setup your environment use:

. /opt/ros/diamondback/setup.bash
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Stats

Asked: 2011-06-13 09:59:04 -0500

Seen: 1,330 times

Last updated: Jun 27 '11